We are continuing to monitor for any further issues.
Posted Apr 25, 2025 - 10:37 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2025 - 10:36 CEST
Identified
Our monitoring has detected performance issues on our DNS nameservers. Engineers are currently investigating the issue. Customers may experience degraded performance on DNS services until the issue has been resolved.
Posted Apr 25, 2025 - 09:30 CEST
This incident affected: Nameservers (ns1.exonet.nl, ns2.exonet.nl, ns3.exonet.eu).